• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Full Release
#11
(06-25-2019, 03:14 PM)paul Wrote: Hi, I also tried the system, so far not much in deep, but I can say for shure it seems a little slow booting, maybe there are to many background "services" loading?
Installation: OK, first boot: OK, start menu -> install 15khz: no problem; maybe yes, it will need a user friendly frontend.

Thanks!

I will be working on something for this but I don't have an eta.

-Ben
MME4CRT Founder / Developer. 

Cool Lubuntu + MME4CRT  Cool

Please donate to the project

YouTube Channel


  Reply
#12
Didn't notice the options, but do now.

  1. When I click a few times the menu gets stuck. Mouse is visible but can't select anything. Right mouse click keeps creating new windows, but can't select anything.
  2. When I'm lucky I can click Install 15Khz system. When I do this an error window appears: 'Failed to execute child process evte ...'. Same error happens when trying to open the browser: 'Failed to execute child process x-www-browser ...'.
  3. Retroarch: pal games on snes are very laggy, did not notice that on previous installs.

Update:
Appears it is the kernel with the interlaced fix that is the source of or related to the cause. Only after I install the kernel the out of memory errors appear:

Kernel panic: not syncing: out of memory and no killable processes...
CPU: 0 PID: 13433 Comm: kworker/u8:4 Not tainted 4.1.28-040128-generic #201607131931

When running watch -d free -m I see that used memory keeps increasing and free memory decreasing, also the buff/cache gets full pretty quick. (I have 8GB memory), until the system is out of memory and the system freezes or crashes. When using rsync the free memory decreases rapidly (around 50-200MB a second) making the system crash very fast.

Pal issue:
Tested pal snes and psx games and they run at 40fps in Native, Dynamic, 1920 and 2560. Somehow, 3840 makes the game run fine at the right fps, 50. So, only super resolution 3840 works properly with pal games, at least on my machine.
  Reply
#13
For those who also encounter out of memory errors with mubuntu's custom kernel like me, what I did was:

* Install mubuntu using the mubuntu installer iso
* compile and install the latest linux kernel 5.1.15 and apply the 15khz patch (03_linux_15khz.diff and 05_linux_15khz_interlaced_mode_fix.diff), using:

https://www.cyberciti.biz/tips/compiling...el-26.html
https://github.com/D0023R/linux_kernel_1.../linux-5.1

* Install 15khz system (reboots system). Mubuntu's kernel is now installed which causes memory problems for me that lead to crashes.
* Make /etc/default/grub GRUB_DEFAULT point to kernel 5.1.15 that we installed in the second step: https://unix.stackexchange.com/questions...el-in-grub.

Retroarch 50 and 60hz, interlaced, pal and ntsc work withouth problems, only a very tiny bit slower than mubuntu's own kernel but without crashes and low memory usage.
  Reply
#14
Ok, I tried a new installation with 31khz, I have a spare 31khz crt and I wanted to try it.
Retroarch load ok at 120hz refresh but if I quit retroarch I have a "out of sync" message: what resolution do you use for the desktop?
Also I didn't have a hard drive with roms during the install: if I plug in a pendrive to test some game I can't find it with "load content" in retroarch.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)