• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installing 15khz desktop resolution on Linux x11
#1
The easiest and best way to perfom this is to create a file in your home directory named ".xprofile" without the quotes.
In this file you will need to add some xrandr command line code. Replacing $output with your output ID that your CRT will be connected to (VGA-0, DVI-1 etc). To find this ID load up a terminal windows and just type "xrandr | grep " connected" | awk '{print$1}' " without the double quotes. this will list all connected devices.
Code:
xrandr --newmode "700x480_59.941002" 13.849698 700 742 801 867 480 490 496 533 interlace -hsync -vsync && xrandr --newmode "700x480_59.941002" 13.849698 700 742 801 867 480 490 496 533 interlace -hsync -vsync
xrandr --addmode $output 700x480_59.941002
xrandr --output $output --mode 700x480_59.941002

Or for simplicity you could run my 15hkz installer which can be found here. Will automate this process for you.
MME4CRT Founder / Developer. 

PayPal   YouTube   Patreon


  Reply
#2
(02-14-2019, 08:59 AM)alphanu Wrote: The easiest and best way to perfom this is to create a file in your home directory named ".xprofile" without the quotes.
In this file you will need to add some xrandr command line code. Replacing $output with your output ID that your CRT will be connected to (VGA-0, DVI-1 etc). To find this ID load up a terminal windows and just type "xrandr | grep " connected" | awk '{print$1}' " without the double quotes. this will list all connected devices.
Code:
xrandr --newmode "700x480_59.941002" 13.849698 700 742 801 867 480 490 496 533 interlace -hsync -vsync && xrandr --newmode "700x480_59.941002" 13.849698 700 742 801 867 480 490 496 533 interlace -hsync -vsync
xrandr --addmode $output 700x480_59.941002
xrandr --output $output --mode 700x480_59.941002

Or for simplicity you could run my 15hkz installer which can be found here. Will automate this process for you.

Hi Alphanu

Is there a way i can add the 640x480@60 to your setup after thescript was run using this xrandr maybe?
I made some tests and seems to work ok with mame and fb alpha games but vertical games revert to a small window interlaced and when you exit the game then retroarch also stays in that small window unless i launch a regular horizontal game again , then the window restores back to fullscreen
I love what you achieved here already doh! Amazing work
  Reply
#3
Hey @Edomatic welcome to the forum.


I can certainly help you get this resolution installed. However, I have to ask some questions.

Firstly, CRTSwitchRes installs and removes core resolutions on the fly. The installed resolution is only for desktop mode, and does not effect what MME4CRT does while running. So, it does sound weird that things change depending on your desktop resolution.

Could you send me some images/pictures of the issue you are talking about?

What resolution type are you using in ReatroArch? native, dynamic, 1920, 2560 or 3840!

Is CRTSwitchRes turned on?

What have you got your monitor index set to?

Is this limited to specific cores or games?

I know some of these may sound like stupid questions, I just want to cover all basis.
MME4CRT Founder / Developer. 

PayPal   YouTube   Patreon


  Reply
#4
(02-16-2019, 08:59 PM)alphanu Wrote: Hey @Edomatic welcome to the forum.


I can certainly help you get this resolution installed. However, I have to ask some questions.

Firstly, CRTSwitchRes installs and removes core resolutions on the fly. The installed resolution is only for desktop mode, and does not effect what MME4CRT does while running. So, it does sound weird that things change depending on your desktop resolution.

Could you send me some images/pictures of the issue you are talking about?
->i will send a picture tomorrow

What resolution type are you using in ReatroArch? native, dynamic, 1920, 2560 or 3840!
->i am using native and “use custom refersh” is off

Is CRTSwitchRes turned on?
->Yes

What have you got your monitor index set to?
->Was on auto i think (will check tomorrow morning !)

Is this limited to specific cores or games?
->Only tested with mame core (0.206) and happens with vertical games on horizontal monitor

I know some of these may sound like stupid questions, I just want to cover all basis.
not a problem i know you want to narrow it down :-)

tomorrow i will make more tests to see if this also occurs in fb alpha core!
  Reply
#5
Hi,
I seem to have found the issue with the vertical games at least..
It is related to attract mode
It's possible that i did not compile properly as some function are missing in attract
When i launch retroarch from commandline, the vertical games work fine in both emulators that i tested (mame core and fb alpha core)
I just saw you also have released a windows version of MM4crt, i will be trying that as i have my windows already setup with groovymame so it would be great to have MM4CRT on the same as i can compare both in that case !
  Reply
#6
(02-18-2019, 12:02 PM)Edomatic Wrote: Hi,
I seem to have found the issue with the vertical games at least..
It is related to attract mode
It's possible that i did not compile properly as some function are missing in attract
When i launch retroarch from commandline, the vertical games work fine in both emulators that i tested (mame core and fb alpha core)
I just saw you also have released a windows version of MM4crt, i will be trying that as i have my windows already setup with groovymame so it would be great to have MM4CRT on the same as i can compare both in that case !

Nice. That good news.

With windows you need to install resolutions with VMMaker. You will have to make sure that you choose static mode in the options and install the list of resolutions that will soon be in the knowledge base.
MME4CRT Founder / Developer. 

PayPal   YouTube   Patreon


  Reply
#7
I just tried the windows version but i cant get it to work just yet (i copied mm4crt exe to the retroarch folder , im using the latest stable retroarch 1.7.6)

I already have about 15 modelines (groovymame’s super resolutions installed with vmmaker) installed on my windows from groovymame through vmmaker and with crtemudriver that (groovyymame )works well with so i have not added anything else yet as i assumed that since these work with crt emudriver and groovymame these should also work for mm4crt (?) with retroarch or...should i uninstall crt emudriver ir can it co-exist?

I have set the advanced option on, selected rgui,set crtres to 15hhz and 2560 and ‘create custom refresh rate’ is set to off
Core provided is set
When i launch a game (mame core)  i have a black screen
Also i noticed the screen gets skewed vertcally so small i cannot read the text anymore, this happens when i set to ‘native’ in switchres
Not sure what i am missing here?
  Reply
#8
(02-18-2019, 08:01 PM)Edomatic Wrote: I just tried the windows version but i cant get it to work just yet (i copied mm4crt exe to the retroarch folder , im using the latest stable retroarch 1.7.6)

I already have about 15 modelines (groovymame’s super resolutions installed with vmmaker) installed on my windows from groovymame through vmmaker and with crtemudriver that (groovyymame )works well with so i have not added anything else yet as i assumed that since these work with crt emudriver and groovymame these should also work for mm4crt (?) with retroarch or...should i uninstall crt emudriver ir can it co-exist?

I have set the advanced option on, selected rgui,set crtres to 15hhz and 2560 and ‘create custom refresh rate’ is set to off
Core provided is set
When i launch a game (mame core)  i have a black screen
Also i noticed the screen gets skewed vertcally so small i cannot read the text anymore, this happens when i set to ‘native’ in switchres
Not sure what i am missing here?

This is a strange one. It sounds like the resolutions are not installed correctly.

Firstly you will need to re install your resolutions via VMmaker. This is because by default these resolutions would have been installed in dynamic mode. You need to install resolutions in static mode with exact integer refresh rates e.g. 2560x224@60

Can you send a list of the resolutions you have installed.

This is a list of resolutions that we currently have.

https://mme4crt.alphanudesign.co.uk/foru...php?tid=24
MME4CRT Founder / Developer. 

PayPal   YouTube   Patreon


  Reply
#9
(02-19-2019, 04:48 PM)alphanu Wrote:
(02-18-2019, 08:01 PM)Edomatic Wrote: I just tried the windows version but i cant get it to work just yet (i copied mm4crt exe to the retroarch folder , im using the latest stable retroarch 1.7.6)

I already have about 15 modelines (groovymame’s super resolutions installed with vmmaker) installed on my windows from groovymame through vmmaker and with crtemudriver that (groovyymame )works well with so i have not added anything else yet as i assumed that since these work with crt emudriver and groovymame these should also work for mm4crt (?) with retroarch or...should i uninstall crt emudriver ir can it co-exist?

I have set the advanced option on, selected rgui,set crtres to 15hhz and 2560 and ‘create custom refresh rate’ is set to off
Core provided is set
When i launch a game (mame core)  i have a black screen
Also i noticed the screen gets skewed vertcally so small i cannot read the text anymore, this happens when i set to ‘native’ in switchres
Not sure what i am missing here?

This is a strange one. It sounds like the resolutions are not installed correctly.

Firstly you will need to re install your resolutions via VMmaker. This is because by default these resolutions would have been installed in dynamic mode. You need to install resolutions in static mode with exact integer refresh rates e.g. 2560x224@60

Can you send a list of the resolutions you have installed.

This is a list of resolutions that we currently have.

https://mme4crt.alphanudesign.co.uk/foru...php?tid=24

Hi Alphanu,

How can i verify the modelings actually installed as static?
When i go to right-click my desktop my desktop is at 640x480 @60HZ
when i select resolutions is do see all 2560x 240,248,256264,272,280,288,448,464,480,496,512,544 and 560
When i launch a game from game core (0.206) it launches but it displays like in the attached picture
So far doh, one game did launch correct: Akai Katana, i check that games resolution in the arcade database and it is at 320x240@60 , that is exact half the desktop resolution..is that why it works and the rest is  squashed?

(02-19-2019, 05:24 PM)Edomatic Wrote:
(02-19-2019, 04:48 PM)alphanu Wrote:
(02-18-2019, 08:01 PM)Edomatic Wrote: I just tried the windows version but i cant get it to work just yet (i copied mm4crt exe to the retroarch folder , im using the latest stable retroarch 1.7.6)

I already have about 15 modelines (groovymame’s super resolutions installed with vmmaker) installed on my windows from groovymame through vmmaker and with crtemudriver that (groovyymame )works well with so i have not added anything else yet as i assumed that since these work with crt emudriver and groovymame these should also work for mm4crt (?) with retroarch or...should i uninstall crt emudriver ir can it co-exist?

I have set the advanced option on, selected rgui,set crtres to 15hhz and 2560 and ‘create custom refresh rate’ is set to off
Core provided is set
When i launch a game (mame core)  i have a black screen
Also i noticed the screen gets skewed vertcally so small i cannot read the text anymore, this happens when i set to ‘native’ in switchres
Not sure what i am missing here?

This is a strange one. It sounds like the resolutions are not installed correctly.

Firstly you will need to re install your resolutions via VMmaker. This is because by default these resolutions would have been installed in dynamic mode. You need to install resolutions in static mode with exact integer refresh rates e.g. 2560x224@60

Can you send a list of the resolutions you have installed.

This is a list of resolutions that we currently have.

https://mme4crt.alphanudesign.co.uk/foru...php?tid=24

Hi Alphanu,

How can i verify the modelings actually installed as static?
When i go to right-click my desktop my desktop is at 640x480 @60HZ
when i select resolutions is do see all 2560x 240,248,256264,272,280,288,448,464,480,496,512,544 and 560
When i launch a game from game core (0.206) it launches but it displays like in the attached picture
So far doh, one game did launch correct: Akai Katana, i check that games resolution in the arcade database and it is at 320x240@60 , that is exact half the desktop resolution..is that why it works and the rest is  squashed?


Ok, i found out that when i set video to "integer: on" , then i have full screen but the resolution is always 640x480 doh
Do these modelings need to be installed in a specific retroarch file? How can i verify what modelings are installed exactly?
i attached screens of the tetrarch video settings too this time
I feel I'm close doh ! :-)


Attached Files Thumbnail(s)
                   
  Reply
#10
last update before i go to dinner Big Grin
when i load a game up in the game core and then load the RGUI go to video and change the resolution ( that seems to be always 640x480) to the correct one, it does work!
I do see that i have the same resolution in there (double ones) , but i cannot see the freq at which they are set , the double ones i mean
Perhaps i need to find a way to clean out all the modes installed and start fresh ? but..how do i do that
The games look great doh excellent work my friend! So just this little hurdle to finish!
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)