• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RPi problem with mame2003+, mame2010
#1
mame2003 plus and mame2010 dont set original refresh rate.. fbalpha do it

for example: neogeo games launched with mame2003+ and mame2010 running at 60hz, fba running them at 59.180
1944 too has problems, 60hz with mame , 59.630 with fbalpha

i missing some options in mame maybe?
  Reply
#2
(03-04-2019, 08:31 PM)FreZeeN Wrote: mame2003 plus and mame2010 dont set original refresh rate.. fbalpha do it

for example: neogeo games launched with mame2003+ and mame2010 running at 60hz, fba running them at 59.180
1944 too has problems, 60hz with mame , 59.630 with fbalpha

i missing some options in mame maybe?

No I don't think you are missing anything. This is could just a core limitation in the RPi, but I am not sure. I believe mame 2016 does this correctly on the RPi but has more overheads.
MME4CRT Founder / Developer. 

Cool Lubuntu + MME4CRT  Cool

Please donate to the project

YouTube Channel


  Reply
#3
(03-06-2019, 09:52 AM)alphanu Wrote:
(03-04-2019, 08:31 PM)FreZeeN Wrote: mame2003 plus and mame2010 dont set original refresh rate.. fbalpha do it

for example: neogeo games launched with mame2003+ and mame2010 running at 60hz, fba running them at 59.180
1944 too has problems, 60hz with mame , 59.630 with fbalpha

i missing some options in mame maybe?

No I don't think you are missing anything. This is probably just a core limitation in the RPi. I believe mame 2016 does this correctly on the RPi but has more overheads.

oh, this is a big limitation.... fba has few games only on rpi... without mame2010 and 2003+ we cant use mm4crt functions on raspberry. a lots games are vertical sync wrong with artifacts..... wer cant fix it?? mame 2003+ is developed actually... asking them to  fix this in easy way? i dont know what i hace to ask them exactly
  Reply
#4
sorry ben if a repost, but is a fix possible for this? what i have to ask to mame2003+ devs for to fix it or can u do somethings?
is this good?
https://github.com/libretro/mame2003-plu...issues/682
  Reply
#5
This is not something I can fix if it is a core issue.

My assumption is that its a core issue as other cores do report the correct refresh rate. I have not done much testing on the RPi though

I will check if this core does report the correct res on x86 Linux

It seems this is by design. there is an answer on the git issue that enables true timing.
MME4CRT Founder / Developer. 

Cool Lubuntu + MME4CRT  Cool

Please donate to the project

YouTube Channel


  Reply
#6
Bypass audio skew (Restart core); to disabled dont fix it

im wrong, "disabled" option fix and work for to send from core the correct refresh rate to mme4crt

sorry
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)