Few questions for 240p - Printable Version

+- MME4CRT Forum (
+-- Forum: MME4CRT (
+--- Forum: General discussion (
+--- Thread: Few questions for 240p (/showthread.php?tid=1806)

Few questions for 240p - atohmdiy - 12-05-2020


I just spend the day trying to make my setup to work, without much success i must say. I own a bvm-20f1e and a mister. In term of simplicity for crt users mister is the ultimate heaven, go to config file, direct video to 1, composite sync to 1, connect a dac and you are ready to go.

For retro arch it seems more complicated to stay polite. I want to play some 480p games (wii or dreamcast) and 240p not yet on mister (some arcade, ps1 etc). I own a small pc with a small passive radeon 230, that should be compatible 240p without super resolution. 
I also build a gbs scaler with gbs control firmware, and i build two passive sync combiner so i can connect my nintendo switch in 480p 4:3 and downscale to 240p. It works, but the gbs is picky at best... 

Anyway i first tried with lakka, but their x86 build seems outdated and for a unknown reason the crt menu is not in the option. So today i try a clean build with the last manjaro with my small pc, and tried to make retroarch (1.9.0) to work.

First i tried to setup the 15khz mode in crt option and see what it does. It create two modeline in my output, one in 15 khz "2560x240p 60hz" and the other in 700x480, which is not 15 khz. There is a subject here about 15 khz and it said retroarch will use 700x480 as default menu resolution, i really want to ear why because i don't understand.
The only way i manage to get the menu working is use xrandr to set the 15khz modeline on the destkop, connect to the bvm, then start retroarch with the proper configuration (15 khz and everything set to 320x240). I get the rgui menu, but impossible to start a game. I tried metal slug 6 with flycast, it's suppose to be 480p native but flycast can be set to 240p in the option, and when this setting is ON you clearly see the game is downscale in 240p. So i try to start flycast and i don't get any image, it seems retroarch, even if i set the 320x240 in the option, still want to switch to 480p somehow, modeline was created for 2560x480 in xrandr.
I also tried a game with psx beetle hw. Same thing, cannot get a working img, it's like the game was in 480p or 480i or something...

I then tried to set the 31khz option, to get a 640x480 that i can downscale to 240p with the gbs. Here it was a complete freakshow... from what i understand, there is two way of playing 240p game in 31khz crt, line double to get 640x480 at 60hz, or go 320x240 at 120hz. retroarch create two modeline that confirm this, but as there is no option to select the method i don't see how it works. Worse, it start to try randomly to set custom refresh rate, first at 120hz, then at 1920hz...
Anyway, never manage to make it works, i try both with hdmi => hdmi to vga dac => or directly VGA => gbs without success. I also tried without the crt option enable, with standard 640x480 in retroarch, without any success, gbs to not recognize my input (when i say it's picky).

I would really like to understand how the resolution switching is done. Also retroarch really need an option for csync, emudriver seems to do it, but i hate windows Dodgy

I really like to try the pre-built img but i have no account with micro$$$oft...